Launchpad PPA for Ruby and Ruby Bindings with the Base Version as 1.9.1

I have started working on a Ruby on Rails project and am using Rails 3.0 as the base version. Rails 3.0 can be installed either with Ruby 1.8.7 or Ruby 1.9.1. I decided to go along with 1.9.1. However I soon found out that a lot of ruby-bindings have not been updated to support Ruby 1.9.1. I did not want a system with both Ruby 1.8.7 and Ruby 1.9.1 versions.

Hence I decided to recompile a few ruby-bindings which I need for my project but do not exist for ruby 1.9.1 version yet. I repackaged those to support ruby 1.9.1 as the base version, solved a few compilation errors that cropped up and added them to a launchpad ppa.

I have also repackaged the ruby 1.9.1 version shipped by Ubuntu and included symlinks like /usr/bin/ruby => /usr/bin/ruby1.9.1, /usr/bin/rake / => /usr/bin/rake1.9.1 etc.

You can add the repository to your system using the following command:’

sudo add-apt-repository ppa:pratikmsinha/rubybindings

If you want further guidance look at this link. It has screenshots and alternate instructions for older ubuntu systems.

The ruby bindings and dependencies I have added till now are:

libxslt-ruby
libcairo-ruby
libsetup-ruby
ruby-pkg-tools
librmagick-ruby (still in the build queue, has been there for hours)

I plan to add more as I go on and as I need other packages. Might even add the 1.9.2 preview3 if I get time.

If anybody needs any specific ruby bindings to be added, leave a comment and I will try my best to get it up there.

About Pratik Sinha

Linux Nerd, Socialist, Atheist, Adventuristic, Nature Lover, Geeky.

2 comments

Leave a Reply